[Zlib-devel] zlib baseline

jbowler at acm.org jbowler at acm.org
Sun Sep 11 15:27:14 EDT 2011

Mark said:
> My preference (not demand) is that the patches be in an email with something you
>write preceding it that provides some context to the group.  Like why these patches
>should be included, what motivated you to write these patches, that I should ignore the
>last seven similar patches that you sent, what tangled series of unfortunate events led
>to the discovery of the problem and the patch, what dreadful consequences will ensue if
>the patch is not applied, and what amazing performance benefits will be realized when
>the patch is applied -- the sort of stuff that would probably not be in the commit message itself.

If you intend to use git am to apply the patches then additional comments in the email will simply get lost.  Maybe there is an option to avoid this, but it's work.

It will be much easier for you, assuming you want to apply the patches without edits, to ask for all the explanation to be in the commit message.  From my point of view when I'm building patches for libpng I much prefer this because by the time I get to sending a block of patches I've forgotten half of what I did.

None of this applies if you tend to fix up patches you receive (e.g. indentation, spelling) before releasing them.  Then you probably just want to use "patch" and do a git commit yourself and it doesn't much matter where the information is in the original email.

John Bowler <jbowler at acm.org>

More information about the Zlib-devel mailing list